Bancos de Dados, ORM, Programação, Scala

Slick 1.0.0 + Play Framework 2.3.4 + Scala 2.11.1

Caso não tenha atualizado seu código legado de Scalaquery e Slick 1.0 para Slick 2.0, será impossível fazê-lo com os pacotes pré-compilados da Typesafe e outros repositórios oficiais.

Nos projetos Play Framework 2.3.* que utilizarem esses JAR’s será necessário compilar as versões antigas com o compilador atual Scala, remover as respectivas linhas libraryDependencies e então instalar manualmente os JAR’s compilados nos diretórios lib/ dos projetos Play.

Outra opção é baixar o código fonte do Slick 1.0 e incluí-lo como dependência do projeto sbt (subprojeto), obrigando sua compilação com o mesmo compilador do resto de sua aplicação.

Atualmente não há builds oficiais dessas versões legadas das bibliotecas para Scala 2.11.1

 

Standard